«

»

Jan 15

Como resolver el error en el SUA del IMSS: “El componente threed32.ocx o uno de sus archivos dependientes no está registrado correctamente falta un archivo o no es válido”

que aparece después de instalar el SUA del IMSS

Al entrar al sistema muestra el mensaje “El componente threed32.ocx o uno de sus archivos dependientes no está registrado correctamente falta un archivo o no es válido” o en ingles “Component threed32.ocx or one of its dependencies not correctly registered: a file is missing or invalid.”

Kx.CloudIngenium.com - El componente threed32.ocx o uno de sus archivos dependientes no está registrado correctamente falta un archivo o no es valido

El componente threed32.ocx o uno de sus archivos dependientes no está registrado correctamente falta un archivo o no es valido

Causa:

El problema aparentemente es que los instaladores del SUA no instalan todas las dependencias requeridas para el funcionamiento del programa. En algunos casos es porque se dañaron algunas librerías del sistema.

Solución:

  • Cerrar todas las aplicaciones
  • En la carpeta de instalación del sistema copiar el archivo SUA.MDB a otra carpeta (en este archivo se encuentra toda la información de patrones y trabajadores)
  • Desinstalar el SUA y todos los complementos
  • Eliminar la carpeta del SUA
  • Descargar del portal del IMSS el instalador para Windows 7, Windows Vista y Windows XP. Este paso es IMPORTANTE. El instalador mencionado aquí es el de la versión 3.3.2. Este instalador carga las librerías requeridas por el sistema.
  • Reinstalar el sistema y verificar el funcionamiento asignando la contraseña
  • Actualizar con la última versión disponible. Aquí es cuando ya puedes mover a la versión adecuada del sistema que al momento de este articulo es la 3.3.8.
  • Copiar el archivo SUA.MDB respaldado, en la carpeta de instalación del sistema (por default C:CobranzaSUA)

En mi caso mi error fue no haber instalado la versión 3.3.2 y después actualizado a la 3.3.8 ya que es un nuevo sistema.

Notas importantes:

En un ambiente multi-sesión(como es una computadora con diferentes usuarios, terminal services o Multipoint) la librería puede ser requerida se instale en cada sesión de usuario donde se vaya a requerir. En este caso lo que yo hice fue sencillamente abrir la sesión del usuario adicional e instalar la versión 3.3.2 en esa sesión encima de mi instalación (mismo directorio). Como fue una instalación inicial no corro riesgos de perder archivos pero si usted ya utilizo el programa en esa ubicación instálelo en otra o respalde y restaure después de instalar. Con esto el programa registra la biblioteca y este nuevo usuario puede utilizar el SUA sin que le aparezca el error arriba mencionado.

Leave a Reply

%d bloggers like this: