Resolved: USB keyboard stops working on Ubuntu installation at language selection

Resolved: USB keyboard stops working on Ubuntu installation at language selection

I am currently working on setting up an ethereum mining rig and I wanted to use Ubuntu as my operating system (no need to pay for a windows license.) However, as I was installing Ubuntu 14.0.4 LTS on my new computer I ran into a curious detail. As soon as I started the installation process my keyboard and mouse stopped working. I was able to go through the initial screen where you select on the boot options that you wish to install Ubuntu. However, as soon as the installation started I lost both my mouse and keyboard on the language selection screen. This was so weird I try to reboot several times until I started reading the error messages and realized it was an issue with the USB controller (by then I had unplugged a lot of peripherals and tried different video cards.)


As I pointed out the issue was with the USB controller. After reading on the internet this is what I was able to gather. This issue happens on newer hardware, particularly the one that comes with USB 3.0. In order for the USB devices (mouse and keyboard) to work you need to make sure you do the following:

  1. Have enabled legacy mode for the USB controller,
  2. enable USB 3.0 devices,
  3. and here is the key: Connect your Mouse and Keyboard on USB 3.0 ports

and that’s it! Some people have reported simply unplugging the devices and connecting them to different ports do the trick; I am guessing the connected them to USB 3.0 ports afterwards. I tried to change the ports and that did not work in my case. I went from a USB 2.0 port to another 2.0 port just to have the light in the mouse turn on initially and then it went off. Others report just enabling “USB Device Legacy Support” would do the trick. In my case that came enabled right off the bat on the BIOS so that wasn’t enough. It was until I read further and realized there was a conflict with new controllers and that you needed to stick to USB 3.0 ports that I got it to work, hence my recommendation and solution to enable legacy mode and use USB 3.0 ports. Hope that helps!


You may also like...

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.