Community Server 2008.5 SP1: Sitemap is not properly generated

After upgrading from CS 2008.5 to CS 2008.5 SP1 the sitemaps are not properly generated. Here is one of the error messages I get:

Server Error in '/' Application.


Requested value 'forum' was not found.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

Exception Details: System.ArgumentException: Requested value 'forum' was not found.

Source Error: 

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace: 

[ArgumentException: Requested value 'forum' was not found.]
   System.Enum.Parse(Type enumType, String value, Boolean ignoreCase) +7530687
   CommunityServer.Components.CSContext.get_ApplicationType() +97
   CommunityServer.Components.UserCookie..ctor(User user) +189
   CommunityServer.Components.UserLastVisitModule.csa_UserKnown(User user, CSEventArgs e) +37
   CommunityServer.Components.CSUserEventHandler.Invoke(User user, CSEventArgs e) +0
   CommunityServer.Components.CSApplication.ExecuteUserEvent(Object EventKey, User user, ObjectState state, ApplicationType appType) +77
   CommunityServer.CSHttpModule.Application_AuthorizeRequest(Object source, EventArgs e) +216
   System.Web.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +68
   System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +75


Version Information: Microsoft .NET Framework Version:2.0.50727.3053; ASP.NET Version:2.0.50727.3053

You may also like...

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.

%d bloggers like this: